jQuery 3.x系でeasingが動かない

jQuery3.x系に乗り換える試みをしている最中なのですが、easingプラグインがそのままでは動きません。
jQueryの公式ページで詳細が書いてあるのですが・・・。

スポンサーリンク

Deprecated: Additional easing function parametersという項目でeasingは引数を1つしか持てなくなると書いてあります。
jQuery Easing Pluginのバージョン1.3.0では引数を複数持っているので全部1つにしなければなりません。
これを直すにはeasingプラグインの最新版にする必要があります。

実は最新版は作者のWebサイトにあるバージョン1.3.0ではなくてGitHubにあるバージョン1.4.0になります。

Webページをちゃんと更新しておいてくださいよ・・・
これでeasingがちゃんと動くようになりました。

スポンサーリンク

Leave a Comment